DOBON.NETプログラミング道掲示板

ツリー一括表示

Nomalアイコン あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー /けい (19/04/29(Mon) 17:14) #34240
Nomalアイコン Re[1]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー /Azulean (19/04/29(Mon) 19:20) #34242
│└Nomalアイコン Re[2]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー /けい (19/04/30(Tue) 13:38) #34244
Nomalアイコン Re[1]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー /魔界の仮面弁士 (19/04/30(Tue) 23:58) #34249
  └Nomalアイコン Re[2]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー /けい (19/05/03(Fri) 12:54) #34253
    └Nomalアイコン Re[3]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー /けい (19/05/03(Fri) 13:01) #34254 解決み!


親記事 / ▼[ 34242 ] ▼[ 34249 ]
■34240 / 親階層)  あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー
□投稿者/ けい 一般人(22回)-(2019/04/29(Mon) 17:14:29)
  • アイコン環境/言語:[Windows10、VB.NET、.NET Framework4.0] 
    分類:[.NET] 

    お世話になります。

    Windows10、VB.NET2015でEXEを開発しています。
    WindowsXP、Windows7、Windows8.1で使用するため、
    .NET Framework=4.0で開発しています。

    この同じ開発環境PCが2台あります(A、Bとします)。

    AでビルドしたEXEは、運用PCで正常に起動します。

    AでビルドしたソリューションをフォルダごとBに移して、
    コードは何もいじらず、
    BでビルドしたEXEは、運用PCで起動時に原因不明のエラーが出ます。
    「動作を停止しました」「「問題が発生したため終了します。この問題を<Report Destination Name>に報告してください」となります。

    ちなみに、別途新規にBで作成、ビルドしたプロジェクトのEXEは、
    運用PCでも正常に起動します。

    考え得るエラー原因の可能性があれば、
    教えてください。

    どうぞよろしくお願いします。

違反を報告
[ □ Tree ] 返信 削除キー/

▲[ 34240 ] / ▼[ 34244 ]
■34242 / 1階層)  Re[1]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー
□投稿者/ Azulean 大御所(507回)-(2019/04/29(Mon) 19:20:31)
  • アイコン推測が難しいですね。

    No34240に返信(けいさんの記事)
    > BでビルドしたEXEは、運用PCで起動時に原因不明のエラーが出ます。
    > 「動作を停止しました」「「問題が発生したため終了します。この問題を<Report Destination Name>に報告してください」となります。

    Windows のイベントログのアプリケーションのツリーに、問題が起きた時刻近辺でエラーが記録されていませんか?
    複数存在すると思いますので、.NET の例外情報が残されていないかを確認してみてください。
    ヒントになるかもしれません。


    また、フォルダーごとコピーした後、B で「リビルド」した場合はどうなりますか?
違反を報告
[ 親 34240 / □ Tree ] 返信 削除キー/

▲[ 34242 ] / 返信無し
■34244 / 2階層)  Re[2]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー
□投稿者/ けい 一般人(24回)-(2019/04/30(Tue) 13:38:18)
  • アイコンNo34242に返信(Azuleanさんの記事)

    ありがとうございます。

    運用PCでのエラー履歴、調べてみます。

    Bでリビルドしても結果は同じでした。
違反を報告
[ 親 34240 / □ Tree ] 返信 削除キー/

▲[ 34240 ] / ▼[ 34253 ]
■34249 / 1階層)  Re[1]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー
□投稿者/ 魔界の仮面弁士 大御所(1226回)-(2019/04/30(Tue) 23:58:59)
  • アイコンNo34240に返信(けいさんの記事)
    > ちなみに、別途新規にBで作成、ビルドしたプロジェクトのEXEは、
    > 運用PCでも正常に起動します。

    既存プロジェクト(および、実験用の新規プロジェクト)は、
    どのような内容なのでしょうか?

    コンソールアプリなのか、WinForm なのか WPF なのか WebApp なのか、
    x86/x64/AnyCPU/AnyCPU32bitPreferred の違いとか、
    参照設定に Interop.*.dll の類が含まれているか否か、
    .config や .manifest に追加の設定が書き込まれているのか否か、
    レジストリの AppCompatFlags の設定有無の状況とか。
違反を報告
[ 親 34240 / □ Tree ] 返信 削除キー/

▲[ 34249 ] / ▼[ 34254 ]
■34253 / 2階層)  Re[2]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー
□投稿者/ けい 一般人(25回)-(2019/05/03(Fri) 12:54:07)
  • アイコンNo34249に返信(魔界の仮面弁士さんの記事)

    ありがとうございます。

    既存プロジェクト、実験用、
    ともに、Winformです。

    実験用は、FormにButtonを置いただけのものでした。
違反を報告
[ 親 34240 / □ Tree ] 返信 削除キー/

▲[ 34253 ] / 返信無し
■34254 / 3階層)  Re[3]: あるWindows10PCでビルドしたEXEがW8.1以下で実行エラー
□投稿者/ けい 一般人(26回)-(2019/05/03(Fri) 13:01:55)
  • アイコン皆様ありがとうございました。

    解決しました。

    開発環境にインストールされているMicrosoft POS for .NETのバージョンが、

    Aでは1.12、Bでは1.14になっていました。

    AでビルドしたソリューションをBで開いた時、

    参照しているMicrosoft.PointOfServiceのプロパティで、

    特定バージョン=Falseのため、

    バージョンが自動的に1.12から1.14になり、

    これでビルドしてEXEを作成したため、

    これがXP等でエラーの原因になったようです。

    会計レジのラインディスプレイでPOSを使用していました。

    Bに1.12もインストールして、ソリューションを開くと、

    参照バージョンは1.12になり、エラーは解決しました。

    ご助言まことにありがとうございました。
解決み!
違反を報告
[ 親 34240 / □ Tree ] 返信 削除キー/


Mode/  Pass/


- Child Tree -